1001 A+B Format (20分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10 ​^6≤a,b≤10^​6. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9  

Sample Output:

-999,991  


#include<iostream>
#include<string>
#include<cmath>
#include<cstdio>
using namespace std;
int main(){
    long A,B,sum,s,m;
    cin>>A>>B;
    sum=A+B;
    if(sum<1000&&sum>-1000)cout<<sum; 
    else if(sum>-1000000&&sum<1000000){
        s=fabs(sum%1000);
        cout<<sum/1000<<',';
        printf("%03d",s);
    }
    else{
        s=fabs(sum%1000);
        cout<<sum/1000000<<',';
        m=fabs((sum%1000000)/1000);
        printf("%03d,%03d",m,s);
    }
    return 0;
}