1003 Emergency (25分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C ​1 ​​ and C ​2 ​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c ​1 ​​ , c ​2 ​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C ​1 ​​ to C ​2 ​​ .

Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C ​1 ​​ and C ​2 ​​ , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4 

#include<bits/stdc++.h>
using namespace std;
#define MAXN 505
#define INF 0x3fffffff
int G[MAXN][MAXN];
int weight[MAXN]={0};
bool vis[MAXN]={false};
int dis[MAXN];
vector<int> pre[MAXN];
int st,ed,n,m,ansnum=0,answ=0;
vector<int> temppath;
void Dijkstra(){
    fill(dis,dis+MAXN,INF);
    dis[st]=0;
    for(int i=0;i<n;i++){
        int u=-1,MIN=INF;
        for(int j=0;j<n;j++){
            if(vis[j]==false&&dis[j]<MIN){
                u=j;
                MIN=dis[j];
            }
        }
        if(u==-1) return;
        vis[u]=true;
        for(int v=0;v<n;v++){
            if(vis[v]==false&&G[u][v]!=INF){
                if(dis[u]+G[u][v]<dis[v]){
                    dis[v]=dis[u]+G[u][v];
                    pre[v].clear();
                    pre[v].push_back(u);
                }
                else if(dis[u]+G[u][v]==dis[v]){
                    pre[v].push_back(u);
                }
            }
        }
    }

}
void dfs(int s){
    if(s==st){
        ansnum++;
        temppath.push_back(s);
        int val=0;
        for(int i=0;i<temppath.size();i++){
            val+=weight[temppath[i]];
        }
        answ=max(answ,val);
        temppath.pop_back();
        return;
    }
    temppath.push_back(s);
    for(int i=0;i<pre[s].size();i++){
        dfs(pre[s][i]);
    }
    temppath.pop_back();
}
int main(){
    fill(G[0],G[0]+MAXN*MAXN,INF);
    cin>>n>>m>>st>>ed;
    for(int i=0;i<n;i++){
        scanf("%d",&weight[i]);
    }
    for(int i=0;i<m;i++){
        int a,b,c;
        scanf("%d%d%d",&a,&b,&c);
        G[a][b]=G[b][a]=c;
    }
    Dijkstra();
    dfs(ed);
    cout<<ansnum<<' '<<answ;
    return 0;
}