1006 Sign In and Sign Out (25分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

#include<iostream>
using namespace std;
struct pn{
    string id="";
    int h1,m1,s1,h2,m2,s2;
    int am,pm;
}p[10004];
int main(){
    int i,j;
    int N;
    cin>>N;
    getchar();
    for(i=0;i<N;i++){
        cin>>p[i].id;
        scanf("%02d:%02d:%02d %02d:%02d:%02d",&p[i].h1,&p[i].m1,&p[i].s1,&p[i].h2,&p[i].m2,&p[i].s2);
        p[i].am=p[i].h1*3600+p[i].m1*60+p[i].s1;
        p[i].pm=p[i].h2*3600+p[i].m2*60+p[i].s2;
        getchar();
    }
    int min=0,max=0;
    for(i=1;i<N;i++){
        if(p[i].am<p[min].am)min=i;
        if(p[i].pm>p[max].pm)max=i; 
    }
    cout<<p[min].id<<' '<<p[max].id;    
    return 0;
}