1013 Battle Over Cities (25分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city ​1 ​​ -city ​2 ​​ and city ​1 ​​ -city ​3 ​​ . Then if city ​1 ​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city ​2 ​​ -city ​3 ​​ .

Input Specification:
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

#include<bits/stdc++.h>
using namespace std;
vector<vector<int> >G;
int visit[1004];
void dfs(int root){
    if(visit[root]==1)return;
    visit[root]=1;
    for(int l=0;l<G[root].size();l++){
        if(visit[G[root][l]]==0&&G[root][l]!=0){
            dfs(G[root][l]);
        }
    }
}
int main(){
    int N,M,P; 
    cin>>N>>M>>P;
    G.resize(N+1);
    for(int i=1;i<=M;i++){
        int x,y;
        scanf("%d %d",&x,&y);
        G[x].push_back(y);
        G[y].push_back(x);
    }
    for(int i=0;i<P;i++){
        int city,n=0;
        scanf("%d",&city);
        fill(visit,visit+N+1,0);        
        visit[city]=1;
        for(int k=1;k<=N;k++){
            if(visit[k]==0){
                dfs(k);
                n++;
            }
        }
        printf("%d\n",n-1);
    }
    return 0;
}