1020 Tree Traversals (25分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

.

#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<cstdio>
#include<algorithm>
using namespace std;
struct node{
    node *Lchild,*Rchild;
    int data;
};

int pre[55],in[55],post[55];
int n;  //结点个数 

node *create(int postL,int postR,int inL,int inR){
    if(postL>postR){
        return NULL;    //后序序列长度小于等于0时,直接返回 
    }
    node * root = new node; //创建一个新结点,用来存放当前二叉树的根结点
    root->data = post[postR];//新结点的数据域为根节点的值
    int k;
    for(k=inL;k<=inR;k++){
        if(in[k]==post[postR]){ //在中序序列中找到in[k]==pre[L]的结点 
            break;
        }
    }
    int numLeft = k-inL;    //左子树的结点个数
    //返回左子树的根结点地址,赋值给root的左指针
    root->Lchild=create(postL,postL+numLeft-1,inL,k-1);
    root->Rchild=create(postL+numLeft,postR-1,k+1,inR);
    return root;
}

int num =0; //已输出的结点个数

void BFS(node *root){
    queue<node*>q;
    node *now;
    q.push(root);
    while(!q.empty()){
        now=q.front();
        q.pop();
        num++;
        cout<<now->data;
        if(num!=n)cout<<' ';
        if(now->Lchild!=NULL)   q.push(now->Lchild);
        if(now->Rchild!=NULL)   q.push(now->Rchild);
    }
} 
int main(){
    cin>>n;
    for(int i=0;i<n;i++)cin>>post[i];
    for(int i=0;i<n;i++)cin>>in[i];
    node *root = create(0,n-1,0,n-1);
    BFS(root);
    return 0;
}