1025 PAT Ranking (25分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank  

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

排序题型。先对各地的考生进行排序并排名,然后合并,合并完再排序排名。

#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<cstdio>
#include<algorithm>
using namespace std;

struct student{
    string id;
    int score,lnum,grank,lrank;
}q[100005];
int cmp(struct student x,struct student y){
    if(x.score!=y.score)    return x.score>y.score;
    else return x.id<y.id; 
}
int main(){
    int N,l=0;
    cin>>N;
    for(int i=0;i<N;i++){
        int K;
        struct student p[350];
        scanf("%d\n",&K);
        for(int j=0;j<K;j++){
            cin>>p[j].id;
            scanf("%d",&p[j].score);
            p[j].lnum=i+1;
        }
        sort(p,p+K,cmp);
        p[0].lrank=1;
        q[l].id=p[0].id;    q[l].score=p[0].score;
        q[l].lnum=p[0].lnum;    q[l++].lrank=p[0].lrank;
        for(int j=1;j<K;j++){
            if(p[j].score==p[j-1].score)    p[j].lrank=p[j-1].lrank;
            else p[j].lrank=1+j;
            q[l].id=p[j].id;    q[l].score=p[j].score;
            q[l].lnum=p[j].lnum;    q[l++].lrank=p[j].lrank;
        }
    }
    sort(q,q+l,cmp);
    q[0].grank=1;
    for(int i=1;i<l;i++){
        if(q[i].score==q[i-1].score)    q[i].grank=q[i-1].grank;
        else    q[i].grank=i+1;
    }
    cout<<l<<endl;
    for(int i=0;i<l;i++){
        cout<<q[i].id<<' '<<q[i].grank<<' '<<q[i].lnum<<' '<<q[i].lrank<<endl;
    }
    return 0;
}