1037 Magic Coupon (25分)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons N ​C ​​ , followed by a line with N ​C ​​ coupon integers. Then the next line contains the number of products N ​P ​​ , followed by a line with N ​P ​​ product values. Here 1≤N ​C ​​ ,N ​P ​​ ≤10 ​5 ​​ , and it is guaranteed that all the numbers will not exceed 2 ​30
​​ .

Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<cstdio>
#include<algorithm>
using namespace std;

int main(){
    vector<long>a,na,b,nb;
    int n,x,max=0;
    cin>>n,x;
    for(int i=0;i<n;i++){
        scanf("%d",&x);
        if(x>=0)a.push_back(x);
        else na.push_back(x);
    }
    cin>>n;
    for(int i=0;i<n;i++){
        scanf("%d",&x);
        if(x>=0)b.push_back(x);
        else nb.push_back(x);
    }
    sort(a.begin(),a.end());
    sort(na.begin(),na.end());
    sort(b.begin(),b.end());
    sort(nb.begin(),nb.end());
    for(int j=b.size()-1,i=a.size()-1;;i--,j--){
        if(i==-1||j==-1)break;
        max+=b[j]*a[i];
    }
    for(int i=0;;i++){
        if(i==nb.size()||i==na.size())break;
        max+=nb[i]*na[i];
    }
    cout<<max<<endl;
    return 0;
}