1049 Counting Ones (30分)

The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.

Input Specification:
Each input file contains one test case which gives the positive N (≤2 ​30 ​​ ).

Output Specification:
For each test case, print the number of 1’s in one line.

Sample Input:

12

Sample Output:

5

数学问题。。感觉智商不够用- -

#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<cstdio>
#include<algorithm>
using namespace std;

int main(){
    int N,ans=0,a=1;
    int l,now,r;
    cin>>N;
    while(N/a){
        l=N/(a*10);
        now=N/a%10;
        r=N%a;
        if(now==0)ans+=l*a;
        else if(now==1)ans+=l*a+r+1;
        else ans+=(l+1)*a;
        a*=10;
    }
    cout<<ans;
    return 0;
}