1053 Path of Equal Weight (30分)

Given a non-empty tree with root R, and with weight W ​i ​​ assigned to each tree node T ​i ​​ . The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2 ​30 ​​ , the given weight number. The next line contains N positive numbers where W ​i ​​ (<1000) corresponds to the tree node T ​i ​​ . Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:
For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A ​1 ​​ ,A ​2 ​​ ,⋯,A ​n ​​ } is said to be greater than sequence {B ​1 ​​ ,B ​2 ​​ ,⋯,B ​m ​​ } if there exists 1≤kB ​k+1 ​​ .

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

以结点降序输出,需要对所有结点的孩子排序,用sort即可,然后dfs从树根到叶子结点累加并且用数组存结点值,当等于M时输出数组即可

#include<bits/stdc++.h>
using namespace std;
struct node{
    int data;
    vector<int>child;
}T[105];
int N,M,S,num[105];
vector<int>path;
int cmp(int a,int b){return T[a].data>T[b].data;} 
void dfs(int root,int sum,vector<int>path){
    path.push_back(T[root].data);
    for(int i=0;i<T[root].child.size();i++)
        dfs(T[root].child[i],sum+T[T[root].child[i]].data,path);
    if(sum==S&&T[root].child.size()==0){
        for(int i=0;i<path.size();i++){
            if(i)cout<<' ';
            cout<<path[i];
        }
        cout<<endl;
    }
}
int main(){
    cin>>N>>M>>S;
    for(int i=0;i<N;i++)
        scanf("%d",&num[i]);
    for(int i=0;i<M;i++){
        int x,n,y;
        scanf("%d %d",&x,&n);
        for(int i=0;i<n;i++){
            scanf("%d",&y);
            T[x].child.push_back(y);
        }
    }
    for(int i=0;i<N;i++)    
        T[i].data=num[i];
    for(int i=0;i<N;i++)    
        sort(T[i].child.begin(),T[i].child.end(),cmp);
    int sum=T[0].data;
    dfs(0,sum,path);    
    return 0;
}