1061 Dating (20分)

Sherlock Holmes received a note with some strange strings: Let’s date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 – since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:
Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:
For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week – that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:

3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm

Sample Output:

THU 14:04

#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<set>
#include<cmath>
#include<queue>
#include<cstdio>
#include<algorithm>
using namespace std;

int main(){
    char data[13][13]={"MON","TUE","WED","THU","FRI","SAT","SUN"};
    int day,hh,mm,is=0;
    string str1,str2,str3,str4;
    getline(cin,str1);
    getline(cin,str2);
    getline(cin,str3);
    getline(cin,str4);
    for(int i=0;i<str1.size();i++){     
        if(str1[i]==str2[i]&&is==1&&((str1[i]>='A'&&str1[i]<='N')||(str1[i]>='0'&&str1[i]<='9'))){
                if(str1[i]>='A'&&str1[i]<='N')  hh=str1[i]-'A'+10;
                else hh=str1[i]-'0';
                break;
        }
        if(str1[i]==str2[i]&&str1[i]>='A'&&str1[i]<='G'&&is==0){
                day=str1[i]-'A';
                is=1;
        }
    }
    for(int i=0;i<str3.size();i++){
        if(str3[i]==str4[i]&&isalpha(str3[i])){
            mm=i;
            break;
        }
    }
    printf("%s %02d:%02d",data[day],hh,mm);
    return 0; 
}