1062 Talent and Virtue (25分)

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people’s talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a “sage(圣人)”; being less excellent but with one’s virtue outweighs talent can be called a “nobleman(君子)”; being good in neither is a “fool man(愚人)”; yet a fool man is better than a “small man(小人)” who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang’s theory.

Input Specification:
Each input file contains one test case. Each case first gives 3 positive integers in a line: N (≤10 ​5 ​​ ), the total number of people to be ranked; L (≥60), the lower bound of the qualified grades – that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification – that is, those with both grades not below this line are considered as the “sages”, and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the “noblemen”, and are also ranked in non-increasing order according to their total grades, but they are listed after the “sages”. Those with both grades below H, but with virtue not lower than talent are considered as the “fool men”. They are ranked in the same way but after the “noblemen”. The rest of people whose grades both pass the L line are ranked after the “fool men”.

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade

where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:
The first line of output must give M (≤N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID’s.

Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

对应乙级题的德才论。输入时对考生在各个区段的分数分等级,写cmp函数时才方便

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct student{
    int id;
    int de;
    int cai;
    int sum_score;
    int dj;
}T[100005],R[100005];
bool cmp(struct student x,struct student y){
    if(x.dj!=y.dj)  return x.dj<y.dj;
    else
        if(x.sum_score!=y.sum_score)    return x.sum_score>y.sum_score;
        else    if(x.de!=y.de)  return x.de>y.de;
                else    return x.id<y.id;
}
int main(){
    int N,L,H,m=0;
    int i,j,k;
    cin>>N>>L>>H;
    for(i=0;i<N;i++){
        scanf("%d %d %d",&T[i].id,&T[i].de,&T[i].cai);
        T[i].sum_score=T[i].de+T[i].cai;
        if(T[i].de<L||T[i].cai<L)
            continue;
        else if(T[i].de>=H&&T[i].cai>=H){
            T[i].dj=1;
        }
        else if(T[i].de>=H&&T[i].cai>=L){
            T[i].dj=2;
        }
        else if(T[i].de>=T[i].cai){
            T[i].dj=3;
        }else{
            T[i].dj=4;
        }
        R[m].cai=T[i].cai;  R[m].de=T[i].de;    R[m].dj=T[i].dj;    R[m].sum_score=T[i].sum_score;  R[m++].id=T[i].id;
    }
    sort(R,R+m,cmp);
    cout<<m<<endl;
    for(j=0;j<m;j++){
        printf("%d %d %d\n",R[j].id,R[j].de,R[j].cai);
    }
    return 0;
}