1064 Complete Binary Search Tree (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key. The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

利用完全二叉树的性质跟搜索树的中序遍历建树
1.完全二叉树可以用数组来存,一个结点的下标为K,则它的左孩子为2*K,右孩子为2K+1(为方便表达,根节点从1开始,而不是0)
2.搜索树的中序遍历是排序的

#include<bits/stdc++.h>
using namespace std;
int bst[1010],num[1010];
int N,idx=1;
void InOrder(int root){
    if(root>N)return;
    InOrder(2*root);
    bst[root]=num[idx++];
    InOrder(2*root+1);
}
int main(){
    cin>>N;
    for(int i=1;i<=N;i++)
        cin>>num[i];
    sort(num+1,num+N+1);
    InOrder(1);
    for(int i=1;i<=N;i++){
        if(i!=1)cout<<' ';
        cout<<bst[i];
    }
    return 0;
}