1066 Root of AVL Tree (25分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

#include<bits/stdc++.h>
using namespace std;
struct node{
    struct node *lchild,*rchild;
    int val;
};
node *rotateLeft(node *root){
    node *temp=root->rchild;
    root->rchild=temp->lchild;
    temp->lchild=root;
    return temp;
}
node *rotateRight(node *root){
    node *temp=root->lchild;
    root->lchild=temp->rchild;
    temp->rchild=root;
    return temp;
}
node *rotateLR(node *root){
    root->lchild=rotateLeft(root->lchild);
    return rotateRight(root);
}
node *rotateRL(node *root){
    root->rchild=rotateRight(root->rchild);
    return rotateLeft(root);
}
int getHeight(node *root){
    if(root==NULL)return 0;
    return max(getHeight(root->lchild),getHeight(root->rchild))+1;
}
node *insert(node *root,int val){
    if(root==NULL){
        root=new node;
        root->val=val;
        root->lchild=root->rchild=NULL;
    }
    else if(val<root->val){
        root->lchild=insert(root->lchild,val);
        if(getHeight(root->lchild)-getHeight(root->rchild)==2){
            root=val<root->lchild->val?rotateRight(root):rotateLR(root);
        }
    }
    else {
        root->rchild=insert(root->rchild,val);
        if(getHeight(root->lchild)-getHeight(root->rchild)==-2){
            root=val>root->rchild->val?rotateLeft(root):rotateRL(root);
        }
    }
    return root;
}
int main(){
    int N,val;
    node *root=NULL;
    cin>>N;
    while(N--){
        scanf("%d",&val);
        root=insert(root,val);
    }
    cout<<root->val;
    return 0; 
}