1067 Sort with Swap(0, i) (25分)

Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3} Swap(0, 3) => {4, 1, 2, 3, 0} Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification: Each input file contains one test case, which gives a positive N (≤10 ​5 ​​ ) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.

Output Specification:
For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

奇葩的排序方式

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<string.h>
#include<algorithm> 
#include<map>
#include<unordered_map>
#include<vector>
#include<queue> 
#include<stack>
#include<string>
using namespace std;


int main(){      
    int n;
    int cnt=0;
    scanf("%d",&n);
    int left=n-1;       //除0外 不再本位置的数字的个数
    vector<int> pos(n); 
    for(int i=0;i<n;i++){
        int num;
        scanf("%d",&num);
        pos[num]=i;
        if(num!=0&&num==i){
            left--;
        }
    }
    int k=1;    //记录除0外不再本位置的最小数
    while(left>0){
        if(pos[0]==0){
            while(k<n){ //如果0在本位置上,那么0与第一个不再本位置上的数交换 
                if(pos[k]!=k){
                    swap(pos[0],pos[k]);
                    cnt++;
                    break;
                }
                k++;
            }
        }
        else{           //如果0不再本位置上,把0和该位置的数交换 
            while(pos[0]!=0){
                swap(pos[0],pos[pos[0]]);
                cnt++;left--;
            }
        } 
    } 
    printf("%d",cnt);
    return 0;    
}