1071 Speech Patterns (25分)

People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.

Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?

Input Specification:
Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:
For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5

#include<bits/stdc++.h>
using namespace std;
int main(){
    string str,temp,ans;
    map<string,int>mp;
    getline(cin,str);
    for(int i=0;i<str.size();i++){
        if(isalnum(str[i])){
            if(str[i]>='A'&&str[i]<='Z')temp.push_back(tolower(str[i]));
            else temp.push_back(str[i]);
        }
        else{
            if(temp.size())mp[temp]++;
            temp.clear();
        }
    }
    int max=0;
    for(auto it=mp.begin();it!=mp.end();it++){
        if(max<it->second){
            ans=it->first;
            max=it->second;
        }
    }
    if(mp.size())cout<<ans<<' '<<max<<endl;
    else cout<<str<<' '<<1<<endl;
    return 0;
}