1084 Broken Keyboard (20分)

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:
Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters A-Z, digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:
For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es

Sample Output:

7TI

#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<unordered_map> 
#include<set>
#include<cstdio>
#include<algorithm>
using namespace std;
int main(){
    string str,s;
    cin>>str>>s;
    map<char,int>mp,cnt;
    for(int i=0;i<s.size();i++)
        mp[s[i]]=1;
    for(int i=0;i<str.size();i++){
        char x=tolower(str[i]),y=toupper(str[i]);
        if(((!mp[x]&&!mp[y]))&&!cnt[y]){
            cout<<y;
            cnt[y]=1;
        }
    }
    return 0;
}