1096 Consecutive Factors (20分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:
Each input file contains one test case, which gives the integer N (1<N<2 ​31 ​​ ).

Output Specification:
For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]factor[2]…*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<set>
#include<cmath>
#include<queue>
#include<cstdio>
#include<algorithm>
using namespace std;

int main(){
    long long N;
    cin>>N;
    long long sqr=(long long)sqrt(1.0*N),ansi=0,anslen=0;
    for(long long i=2;i<=sqr;i++){
        long long temp=1,j=i;
        while(1){
            temp*=j;
            if(N%temp)break;
            if(j-i+1>anslen){
                ansi=i;
                anslen=j-i+1;
            }
            j++;
        }
    }
    if(anslen==0)   cout<<1<<endl<<N;
    else{
        cout<<anslen<<endl;
        for(long long i=0;i<anslen;i++){
            cout<<ansi+i;
            if(i<anslen-1)cout<<'*';
        }
    }
    return 0;
}