1099 Build A Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key. The right subtree of a node contains only nodes with keys greater than or equal to the node’s key. Both the left and right subtrees must also be binary search trees. Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

图略

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

先根据给出的编号确定树的结构,每个结点插入的值都要满足搜索树的性质,可以先对序列排序,然后中序插入遍历插入结点值,最后层序遍历输出即可。

#include<bits/stdc++.h>
using namespace std;
struct node{
    int data,lchild,rchild;
}T[10005];
int num[1010],l=0,ok=0;
void build(int root){
    if(root==-1)return;
    build(T[root].lchild);
    T[root].data=num[l++];
    build(T[root].rchild);
}
void bfs(int root){
    queue<int>q;
    q.push(root);
    while(!q.empty()){
        int i=q.front();
        q.pop();
        if(ok++)cout<<' ';
        cout<<T[i].data;
        if(T[i].lchild!=-1)q.push(T[i].lchild);
        if(T[i].rchild!=-1)q.push(T[i].rchild);
    }
}
int main(){
    int N;
    cin>>N;
    for(int i=0;i<N;i++)
        cin>>T[i].lchild>>T[i].rchild;
    for(int i=0;i<N;i++)
        cin>>num[i];
    sort(num,num+N);
    build(0);
    bfs(0);
    return 0;
}