1100 Mars Numbers

People on Mars count their numbers with base 13:

Zero on Earth is called “tret” on Mars. The numbers 1 to 12 on Earth is called “jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec” on Mars, respectively. For the next higher digit, Mars people name the 12 numbers as “tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou”, respectively.
For examples, the number 29 on Earth is called “hel mar” on Mars; and “elo nov” on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:
For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

.

#include<bits/stdc++.h>
using namespace std;
int main(){
    string mp1[13]={"tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec"};
    string mp2[13]={"tret","tam", "hel","maa","huh", "tou", "kes", "hei","elo","syy",   "lok", "mer", "jou"};
    int N;
    cin>>N;
    getchar();
    while(N--){
        string str;
        int num;
        getline(cin,str);
        if(str[0]>='0'&&str[0]<='9'){
            sscanf(str.c_str(),"%d",&num);
            if(num%13){
                if(num/13)  cout<<mp2[num/13];              
                if(num>13)  cout<<' ';
                cout<<mp1[num%13];
            }
            else    cout<<mp2[num/13];
        }
        else{
            int k=0;
            while(str[k]!=' '&&k<str.size())k++;
            int l=k;
            while(str[l]==' '&&l<str.size())l++;
            string stra=str.substr(0,k),strb;
            int a,b;
            if(k!=str.size()){
                for(a=0;a<13;a++)
                    if(stra==mp2[a])break;
                strb=str.substr(l,str.size()-l);
                for(b=0;b<13;b++)
                    if(strb==mp1[b])break;              
                cout<<a*13+b;
            }
            else {
                for(a=0;a<13;a++)
                    if(stra==mp1[a])break;          
                for(b=1;b<13;b++)
                    if(stra==mp2[b])break;
                if(a==13)cout<<b*13;
                else cout<<a;
            }
        }
        cout<<endl;
    }
    return 0;
}