1144 The Missing Number (20分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10 ​5 ​​ ). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:
Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

#include<bits/stdc++.h>
#include<vector>
#include<string>
#include<map>
using namespace std;
unordered_map<int,int>mp;
int main(){
    int N,a[100005],max=0;
    cin>>N;
    for(int i=0;i<N;i++){
        scanf("%d",&a[i]);
        mp[a[i]]=1;
        if(a[i]>0&&a[i]>max)
            max=a[i];
    }
    for(int i=1;i<=max+1;i++){
        if(mp[i]==0){
            cout<<i;
            return 0;
        }
    }
    return 0;
}