1146 Topological Order (25分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:
Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

考查拓扑排序,选择一个顶点后,判断是否存在点有指向该顶点的边,有则非拓扑排序序列,否则将该顶点所指向其他顶点的边删除,再继续判断下一个点。

#include<bits/stdc++.h>
using namespace std;
vector<int>G[1005];
int N,M,K,ok;
int main(){
    cin>>N>>M;
    for(int i=0;i<M;i++){
        int a,b;
        scanf("%d %d",&a,&b);
        G[a].push_back(b);
    }
    cin>>K;
    for(int i=0;i<K;i++){
        int is=1,a[N];
        vector<int>temp[1005];
        for(int j=1;j<=N;j++)temp[j]=G[j];
        for(int j=0;j<N;j++){
            scanf("%d",&a[j]);
        }
        for(int j=0;j<N;j++){
            for(int k=1;k<=N;k++){
                for(int l=0;l<temp[k].size();l++){
                    if(temp[k][l]==a[j]){
                        is=0;
                        break;
                    }
                }
                if(is==0)break;
            }
            if(is==0)break;
            while(temp[a[j]].size())temp[a[j]].pop_back();
        }
        if(is==0&&ok++) printf(" ");
        if(is==0)printf("%d",i);
    }
    return 0;
}