1077 Kuchiguse (20分)
The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:
Itai nyan~ (It hurts, nyan~)
Ninjin wa iyada nyan~ (I hate carrots, nyan~)
Now given a few lines spoken by the same character, can you find her Kuchiguse?
Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.
Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.
Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
Sample Output 1:
nyan~
Sample Input 2:
3
Itai!
Ninjinnwaiyada T_T
T_T
Sample Output 2:
nai
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<cstdio>
#include<algorithm>
using namespace std;
int main(){
int N;
string max,s[101];
cin>>N;
getchar();
for(int i=0;i<N;i++){
getline(cin,s[i]);
}
for(int i=1;i<1005;i++){
string temp;
int is=1;
for(int k=1;k<=i;k++){
temp.push_back(s[0][s[0].size()-k]);
}
for(int j=1;j<N;j++){
string str;
for(int l=1;l<=i;l++){
str.push_back(s[j][s[j].size()-l]);
}
if(str!=temp||s[0].size()<=max.size()||s[j].size()<=max.size()){
is=0;
break;
}
}
if(is)max=temp;
else break;
}
reverse(max.begin(),max.end());
if(max.size())cout<<max;
else cout<<"nai"<<endl;
return 0;
}