1122 Hamiltonian Cycle (25分)
The “Hamilton cycle problem” is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a “Hamiltonian cycle”.
In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:
n V 1 V 2 … V n
where n is the number of vertices in the list, and V i ’s are the vertices on a path.
Output Specification:
For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.
Sample Input:
6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
Sample Output:
YES
NO
NO
NO
YES
NO
#include<bits/stdc++.h>
using namespace std;
int G[205][205],N,M,K,L;
int main(){
cin>>N>>M;
for(int i=0;i<M;i++){
int a,b;
scanf("%d %d",&a,&b);
G[a][b]=G[b][a]=1;
}
cin>>L;
for(int i=0;i<L;i++){
scanf("%d",&K);
int num[K],is=1,st,mp[N+1];
fill(mp,mp+N+1,0);
for(int j=0;j<K;j++){
scanf("%d",&num[j]);
}
st=num[0];
for(int j=1;j<K;j++){
if(mp[num[j]]==1||G[num[j]][num[j-1]]==0){
is=0;
break;
}
mp[num[j]]=1;
}
if(st==num[0])
for(int j=1;j<=N;j++){
if(mp[j]==0){
is=0;
break;
}
}
else is=0;
printf("%s\n",is?"YES":"NO");
}
return 0;
}