1004 Counting Leaves (30分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

多叉树的实现,统计每一层的叶子结点数,先计算树的高度,然后bfs遍历每一层实现统计。

#include<bits/stdc++.h>
using namespace std;
struct node{
    int data;
    vector<int>child;
}T[105];
int sum,m,L;
void bfs(int root,int k){
    if(T[root].child.size()==0&&k==m)
        sum++;
    for(int i=0;i<T[root].child.size();i++)
        bfs(T[root].child[i],k+1);
}
int getheight(int root){
    int H,max=0;
    for(int i=0;i<T[root].child.size();i++){
        H=getheight(T[root].child[i]);
        if(H>max)max=H;
    }
    return max+1;
}
int main(){
    int N,K;
    cin>>N>>K;
    for(int i=1;i<=K;i++){
        int x,n,child;
        cin>>x>>n;
        for(int j=0;j<n;j++){
            cin>>child;
            T[x].child.push_back(child);
        }
    }
    int H=getheight(1);
    for(m=1;m<=H;m++){
        sum=0;
        bfs(1,1);
        if(m!=1)cout<<' ';
        cout<<sum;
    }
    return 0;
}