1052 Linked List Sorting (25分)

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive N (<10 ​5 ​​ ) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−10 ​5 ​​ ,10 ​5 ​​ ], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:
For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

用sort排序即可 注意:如果链表结点个数为0,则输出:0 -1

#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<cstdio>
#include<algorithm>
using namespace std;
struct node{
    int data=11111,next;
}p[1000005];
int cmp(int x,int y){   return p[x].data<p[y].data;}
int main(){
    int N,first,ad;
    vector<int>ans;
    cin>>N>>first;
    for(int i=0;i<N;i++){
        scanf("%d",&ad);
        scanf("%d %d",&p[ad].data,&p[ad].next);
    }
    while(first!=-1){
        ans.push_back(first);
        first=p[first].next;
    }
    sort(ans.begin(),ans.end(),cmp);
    if(ans.size())printf("%d %05d\n",ans.size(),ans[0]);
    else printf("0 -1");
    for(int i=0;i<ans.size();i++){
        if(i!=ans.size()-1)printf("%05d %d %05d\n",ans[i],p[ans[i]].data,ans[i+1]);
        else printf("%05d %d -1\n",ans[i],p[ans[i]].data);
    }
    return 0;
}