1153 Decode Registration Card of PAT (25分)

A registration card number of PAT consists of 4 parts:

the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
the 2nd - 4th digits are the test site number, ranged from 101 to 999;
the 5th - 10th digits give the test date, in the form of yymmdd;
finally the 11th - 13th digits are the testee’s number, ranged from 000 to 999.
Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤10 ​4 ​​ ) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner’s score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level; Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number; Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card. Output Specification:
For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed); for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score; for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt’s, or in increasing order of site numbers if there is a tie of Nt. If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

写得真乱。。每次查询,应该用两个字符串直接读取两个查询条件,就没那么麻烦了

#include<bits/stdc++.h>
using namespace std;
struct student{
    string card;
    int score;
};
vector<student>stu;
int cmp(struct student a,struct student b){
    if(a.card[0]!=b.card[0])return a.card[0]>a.card[0]; 
    else if(a.score!=b.score)return a.score>b.score;
    else return a.card<b.card;
}
int cmp2(struct student a,struct student b){
    if(a.score!=b.score)return a.score>b.score;
    else return a.card<b.card;
}
int main(){
    int N,M;
    cin>>N>>M;
    for(int i=0;i<N;i++){
        student temp;
        getchar();
        cin>>temp.card;
        scanf("%d",&temp.score);
        stu.push_back(temp);
    }
    for(int i=1;i<=M;i++){
        int choose,empty=1;
        scanf("%d",&choose);
        printf("Case %d: %d ",i,choose);
        if(choose==1){
            getchar();
            char ch;
            scanf("%c",&ch);
            printf("%c\n",ch);
            vector<student>temp;
            for(int j=0;j<stu.size();j++){
                if(stu[j].card[0]==ch){
                    temp.push_back(stu[j]);
                }
            }
            sort(temp.begin(),temp.end(),cmp);
            if(temp.size()){
                empty=0;
                for(int k=0;k<temp.size();k++){
                    printf("%s %d\n",temp[k].card.c_str(),temp[k].score);
                }
            }
        }
        else if(choose==2){
            string num;
            int sum=0,n=0;
            getchar();
            scanf("%s",num.c_str());
            printf("%s\n",num.c_str());
            for(int j=0;j<stu.size();j++){
                string temp;
                for(int k=1;k<=3;k++)   temp.push_back(stu[j].card[k]);
                if(temp==num.c_str()){
                    n++;
                    sum+=stu[j].score;
                }
            }
            if(n){
                empty=0;
                printf("%d %d\n",n,sum);                
            }
        }
        else if(choose==3) {
            string t;
            scanf("%s",t.c_str());
            printf("%s\n",t.c_str()); 
            unordered_map<string,int>mp;
            for(int j=0;j<stu.size();j++){
                string num;
                for(int k=4;k<10;k++) num.push_back(stu[j].card[k]);
                if(num==t.c_str()){
                    string str;
                    for(int p=1;p<=3;p++)str.push_back(stu[j].card[p]);
                    mp[str]++;
                }
            }
            vector<student>temp(mp.size());
            int l=0;
            for(auto it=mp.begin();it!=mp.end();it++){
                temp[l].card=it->first;
                temp[l++].score=it->second;
            }
            sort(temp.begin(),temp.end(),cmp2);
            if(temp.size()){
                empty=0;
                for(int j=0;j<temp.size();j++){
                    printf("%s %d\n",temp[j].card.c_str(),temp[j].score);
                }
            }
        }
        if(empty)printf("NA\n");
    }
    return 0;
}