1154 Vertex Coloring (25分)

A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10 ​4 ​​ ), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:
For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

that no two vertices sharing the same edge have the same color.这句话理解半天。。

#include<bits/stdc++.h>
using namespace std;
vector<int>G[10005];
int main(){
    int N,M,K;
    cin>>N>>M;
    int x,y;
    for(int i=0;i<M;i++){
        scanf("%d %d",&x,&y);
        G[x].push_back(y);
        G[y].push_back(x);
    }
    cin>>K;
    for(int i=0;i<K;i++){
        int color[N],is=1;
        unordered_map<int,int>mp;
        for(int j=0;j<N;j++){
            scanf("%d",&color[j]);
            mp[color[j]]=1;
        }
        for(int j=0;j<N;j++){
            
            for(int k=0;k<G[j].size();k++){
                if(color[j]==color[G[j][k]]){
                    is=0;
                    break;
                }
            }
            if(is==0)break;
        }
        if(is)printf("%d-coloring\n",mp.size());
        else printf("No\n");
    }
    return 0;
}