1015 Reversible Primes (20分)
A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (<10 5 ) and D (1< D ≤ 10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.
Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int prime(int x){
if(x<2)return 0;
for(int i=2;i*i<=x;i++){
if(x%i==0)return 0;
}
return 1;
}
int change(int x,int d){
vector<int>num;
while(x){
num.push_back(x%d);
x/=d;
}
int sum=0;
for(int i=0;i<num.size();i++)
sum=sum*d+num[i];
if(prime(sum))return 1;
else return 0;
}
int main(){
int n,d;
while(1){
cin>>n>>d;
if(n<0)return 0;
if(prime(n)&&change(n,d))
cout<<"Yes"<<endl;
else cout<<"No"<<endl;
}
}