1023 Have Fun with Numbers (20分)
Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!
Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.
Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.
Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.
Sample Input:
1234567899
Sample Output:
Yes
2469135798
.
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<set>
#include<cmath>
#include<queue>
#include<cstdio>
#include<algorithm>
using namespace std;
string dnum,num;
int omp[10],is=1,jw=0;
void add(string num){
reverse(num.begin(),num.end());
for(int i=0;i<num.size();i++){
omp[num[i]-'0']++;
dnum.push_back(((num[i]-'0')*2+jw)%10+'0');
jw=(num[i]-'0')*2/10;
}
if(jw) dnum.push_back(jw+'0');
}
int main(){
cin>>num;
add(num);
for(int i=0;i<dnum.size();i++) omp[dnum[i]-'0']--;
for(int i=0;i<10;i++)
if(omp[i])is=0;
reverse(dnum.begin(),dnum.end());
printf("%s\n%s",is?"Yes":"No",dnum.c_str());
}