1038 Recover the Smallest Number (30分)
Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.
Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤10
4
) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.
Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287
#include<bits/stdc++.h>
using namespace std;
struct number{
string num;
}p[10005];
int cmp(struct number a,struct number b){
return a.num+b.num<b.num+a.num;
}
int main(){
int N,is=0;
cin>>N;
for(int i=0;i<N;i++)
cin>>p[i].num;
sort(p,p+N,cmp);
string ans;
for(int i=0;i<N;i++){
for(int j=0;j<p[i].num.size();j++){
if(is||p[i].num[j]!='0'){
is=1;
ans.push_back(p[i].num[j]);
}
}
}
if(ans.size())cout<<ans;
else cout<<0;
return 0;
}