1054 The Dominant Color (20分)
Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2
24
). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.
Output Specification:
For each test case, simply print the dominant color in a line.
Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24
数的范围大,用map,怕超时用不排序的unordered_map
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<unordered_map>
#include<cmath>
#include<set>
#include<queue>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int main(){
int n,m,a[850][650],x;
cin>>n>>m;
unordered_map<int,int>mp;
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
scanf("%d",&x);
mp[x]++;
}
}
int maxn=0,num;
for(auto it=mp.begin();it!=mp.end();it++){
if(maxn<it->second){
num=it->first;
maxn=it->second;
}
}
cout<<num;
return 0;
}