1002 A+B for Polynomials (25分)
This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
where K is the number of nonzero terms in the polynomial, N (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
double a[1003];
struct pl{
double xs;
int zs;
}p[1004];
int cmp(struct pl x,struct pl y){return x.zs>y.zs;}
int main(){
int ka,kb,x=0;
int i,zs;double xs;
cin>>ka;
for(i=0;i<ka;i++){
cin>>zs>>xs;
a[zs]=xs;
}
cin>>kb;
for(i=0;i<kb;i++){
cin>>zs>>xs;
if(a[zs]) a[zs]+=xs;
else a[zs]=xs;
}
for(i=0;i<=1000;i++){
if(a[i]){
p[x].xs=a[i];
p[x].zs=i;
x++;
}
}
sort(p,p+x,cmp);
cout<<x;
for(i=0;i<x;i++)printf(" %d %.1f",p[i].zs,p[i].xs);
return 0;
}